Incorrect "Noah ES Payment Failed" mail
Incident Report for Noah ES Status
Update
We are continuing to work on a fix for this issue.
Posted May 03, 2024 - 18:13 UTC
Identified
An issue has been identified and is being corrected.
For more information see https://himsanoah.atlassian.net/wiki/spaces/NESP/pages/3846308045/Noah+ES+Payment+Failed+Message+May+2024
Posted May 03, 2024 - 18:10 UTC
This incident affects: Email Notification Service and Payment Processing.