Noah ES (EU): Login Problems

Incident Report for Noah ES Status

Resolved

The incident has been resolved.
Posted Aug 17, 2026 - 08:14 UTC

Monitoring

Self-heal features are reporting that the issue has been resolved. HIMSA will continue to monitor.
Posted Aug 17, 2026 - 08:06 UTC

Investigating

HIMSA has been notified of an issue in Noah ES preventing use of the service. HIMSA is investigating.
Affected Regions: Europe
Posted Aug 17, 2026 - 08:02 UTC
This incident affected: Noah ES Core Services (Authentication Service (IdP), Noah ES Client, Noah ES Portal) and Data Migration Services.